Workarounds in vray.

As good as V-Ray for maya is it also has some bugs.

 

I will write down the ones i find here and if i have a workaround it will be here aswell.

 

1. Shaders appearing has a grey preview only.

Im not sure why or when this happens but sometimes when opening the hypershade all shaders are grey.

 

To get them working again there is a few things to try.  In the render globals go to the VRay tab and at the bottom

expand the Vray UI tab. In there uncheck Render swatches  for VRayMtl and V-Ray lights and then check it again.

Next thing to try is to select a VRayMtl and open the Attribute editor. At the top, expand Swatch properties tab and uncheck Auto update and check it again, then check Always render this swatch.

 

2. Attribute editor is missing vray extra attributes or show everything in numeric values. This is a known bug and the solution seems to be turning off history in maya and turning it back on.

 

3. Render layer overrides don’t show with orange text. This small ui bug got me confused a while ago when working on scenes with 10 render layers, different attributes seemed like they had lost their overrides.

The simple solution to this is that you need to click somewhere in the active ui part, Attribute editor, Render globals and so on to get the overrides to show up.

Advertisements

One Response to “Workarounds in vray.”

  1. to fix the extra attributes you can also copy the tab – didn’t know about the history trick – thx!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: